Installer sur Linux

GeoFIS fournit des paquets Debian à installer sur certaines distributions Linux. Toutes les dépendances nécessaires seront installés avec GeoFIS (vous devez accepter les dépendances pour que GeoFIS fonctionne correctement).

Pour utiliser GeoFIS, l’environnement de développement Java (JDK) doit être installé sur votre ordinateur (version >= 1.8).
Cette version n’est pas installée par defaut sur les anciennes distributions Linux.
Suivez les instructions pour installer OpenJDK 8 sur Debian 8.x « Jessie ».
Suivez les instructions pour installer OpenJDK 8 sur Ubuntu 14.04 « Trusty ».

Certaines opérations GeoFIS nécessitent que le logiciel R (version >= 3.0) soit installé pour fonctionner.
Votre distribution Linux contient un logiciel R par défaut. Nous vous recommandons d’utiliser le dernier logiciel R disponible pour votre distribution, certains paquets R utilisés par GeoFIS ne sont pas disponibles (ou ont des bugs) avec une ancienne version de R. Voir problèmes connus avec R.
Suivez les instructions pour installer ou mettre à jour le logiciel R sur Linux.
Au premier lancement de GeoFIS, ou après une mise à jour majeure du logiciel R, les paquets R requis seront compilés et installés (cela peut être assez long…).

GeoFIS a besoin que la bibliothèque ‘libgdal-dev’ soit installée sur votre distribution Linux (version requise > = 1.11.4 par le paquet R rgdal). Cette version n’est pas disponible sur les anciennes distributions Linux.
Pour Ubuntu 16.04 « Xenial » ou 14.04 « Trusty », vous pouvez installer la version la plus récente de ‘libgdal-dev’ à partir du dépôt UbuntuGIS.
Pour Debian 8.x « Jessie », vous devez installer GDAL depuis les sources.

Sélectionnez votre système d’exploitation, et suivez les instructions « Ajouter le dépôt et installer manuellement » pour installer le paquet GeoFIS pour votre distribution Linux :

Pour Mint 19.x, Sélectionnez le système d’exploitation Ubuntu et installez la version xUbuntu 18.04.
Pour Mint 18.x, Sélectionnez le système d’exploitation Ubuntu et installez la version xUbuntu 16.04.
Pour Mint 17.x, Sélectionnez le système d’exploitation Ubuntu et installez la version xUbuntu 14.04.
Pour LMDE 3, Sélectionnez le système d’exploitation Debian et installez la version Debian 9.0.
Pour LMDE 2, Sélectionnez le système d’exploitation Debian et installez la version Debian 8.0.
Pour les autres distributions Linux installer GeoFIS sur Docker ou installer GeoFIS depuis les sources

Lancer GeoFIS depuis le bureau ou un terminal /opt/geofis/geofis.sh.

Des données d’entraînement sont disponibles dans le dossier « /var/lib/geofis/data ».

Les mises à jour de GeoFIS seront proposées avec les mises à jour du système.

En installant GeoFIS vous acceptez le contrat de licence de logiciel libre CeCILL